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Building Effects with Multiple Layers 
In the last tutorial, you built a complicated effect by stacking slightly modified versions 

of the same video clip. Although it might seem simple, this is an important concept, and 

an approach that many beginning compositors often miss. It can be tempting to try to 

create a lot of effects inside of one layer by applying filters and masks. However, most of 

the time, you’ll need to break an effect down into a number of different processes, and 

use a separate copy of your video for each process. For many effects, you’ll create 

several duplicates of a video clip and spend a lot of time cutting a different alpha channel 

for each clip. These clips will be filtered and manipulated separately, and then stacked on 

top of each other. 

In the next tutorial, we will combine layer stacking with rotoscoping to create a 

complicated effects shot of a person literally sneezing his head off. 

Exploding Heads 
In this tutorial, we’re going to create a complex composite using several instances of the 

same video clip. By combining several hand-cut mattes, a lot of hand-painting, and an 

After Effects filter called Shatter, (which is part of the standard After Effects  package), 

we will create a movie showing a person’s head shattering into fragments after an over-

strenuous sneeze. (In the industry, this type of film is known as “high concept.”) 

When planning an effect such as this, you might not be able to imagine exactly what 

post-production manipulations the shot will require. Most likely, you’ll have to feel your 

way through the process and add new layers and filters as necessary. However, you can 

make some informed decisions about how to begin. 

The Sneeze tutorial folder contains a video clip called sneeze orig.mov. This is our source 

footage that shows a person sneezing, and then stumbling out of frame. To see how the 

shatter plug-in works, load the sneeze orig.mov footage into After Effects and apply the 

Shatter effect. You’ll see that the entire image shatters, and in a form that doesn’t really 

look like a shattery explosion (Figure 18.18). 
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Figure 18.18 The Shatter filter is nice, but we want to change its shatter settings to create more of 
an explosion effect, and we want the plug-in to only affect the actor’s head. 

We can easily adjust the plug-in’s settings to create a more appropriate type of shatter. 

(Figure 18.19) However, since we want just the head to shatter, we need to mask out the 

rest of the frame using an alpha channel. This will be our starting point. 

 

 

Figure 18.19 The Shatter filter can easily be modified to create a more appropriate explosion-type 
effect, but we still need to find a way of constraining the effect to just the actor’s head. 
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Step 1: Create an Alpha Channel of the Head 
The Shatter filter works by taking the image of a single frame, shattering it into pieces, 

and then animating those pieces so that they fly across the subsequent frames of the 

movie. Therefore, our first step is to decide when in the movie we want the shatter to 

occur. That frame will be shattered by the Shatter plug-in. However, as we’ve already 

seen, we don’t want to shatter the entire frame. Instead, we want to create an alpha 

channel to limit the shatter effect to just the head. Because the shatter effect only operates 

on one frame, we only have to create an alpha channel for that single frame. We chose 

00:00:03:10 (or frame 101) since there’s a nice, slight head jerk that will add to the 

feeling of impact. 

Choosing Time Display in After Effects 

You can change the time display in After Effects so that it displays 

frame numbers instead of hours:minutes:seconds:frames. For this 

tutorial, we ofted for frame number display, which you can activate 

by going to File>Project Settings, and selecting Frames. (In some 

older versions of After Effects, this setting is kept under 

File>Preferences>Time.) 

For this tutorial, we will be creating masks as separate files, rather than as alpha channels 

embedded in our movie files. This will allow for more flexibility to correct and change 

the mattes. As we did in the last tutorial, we’re going to create our alpha channel using 

Photoshop. In After Effects, export a still of frame 101 from the sneeze orig.mov movie. 

To do this, load the sneeze orig.mov movie into a composition, select its layer in the Time 

Layout window, and then choose Composition>Save Frame As. 

Rather than create a selection as we did in previous tutorials, you can simply paint over 

the background areas with black paint, and the foreground areas with white paint. 

Because you probably won’t need to re-edit this image, go ahead and use Photoshop’s 

Image Size command to perform a 90% horizontal scale. Scaling your image here will 

save you a tiny bit of rendering time later. Save this image as a Photoshop file called 

head matte.psd (Figure 18.20). 
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Fig 18.20,Still frame (top), and accompanying matte (bottom). 

 
Step 2: Set Up Your Project 
Now, go back to After Effects, create a project, and import the sneeze orig.mov movie 

and the head matte.psd file that you just created. Make a new composition with the 

appropriate size and duration to hold the movie. Name this comp Main. 

In a moment, we will use our new matte to confine the effects of the Shatter plug-in to 

the actor’s head. Since this matte will eliminate the rest of the frame, we will see only a 

shattering head. Therefore, as we did in our previous tutorial, we will need to layer two 
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copies of the same movie on top of each other. The top one will have the matte and the 

Shatter effect applied, and the bottom will serve to keep our “background” visible. 

Place the sneeze orig.mov file into your composition. This layer will be our background. 

Step 3: Prepare the Second Layer 
At this point, we could start heaping more layers on top of the first one. In the interest of 

housekeeping, though, we’re going to isolate some effects and layers by putting them in 

their own compositions. These compositions can then be nested inside our main 

composition to ease organization of our project. 

Create another composition with the same settings as the first, but name this one 

Exploding head. 

Add the sneeze orig.mov clip to the Exploding Head composition, and double-click on it 

in the Time Layout window. This will open the movie in its own layer and allow you to 

easily set the in-point. Drag the current time marker to frame 100, and click the In-Point 

button. Close the window. 

With the in-point set here, the movie in this comp now starts one frame before we want 

our explosion to begin (the Shatter effect doesn’t become visible until the second frame 

of a clip). 

Now, import the head matte.psd image you created earlier. Add it to your Exploding 

Head comp and disable the matte’s visibility by clicking its Eye icon in the Time Layout 

window. Click on the sneeze orig.mov file in the Exploding Head Timelinee window to 

select it. Earlier in this chapter we used the Set Channels filter to define a separate file as 

an alpha channel for our current layer. Now we’re going to use the Set Matte filter. With 

the sneeze.org layer selected, choose Effect>Channel>Set Matte. Set the Take Matte 

From Layer popup to Head Matte.psd, to indicate that we will be using that layer as the 

source for our matte. In the Use for Matte popup select Luminance to indicate that we 

will build our alpha channel from the luminance information in the Head Matte layer. 

(Figure 17.21). 
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Figure 17.21 Our second composition, Exploding Head, after the footage and matte layers have 
been added. Note the Set Channel filter, which is used to activate the matte. 
 

Step 4: Add the Shatter 
Now, put the Exploding Head comp inside the Main comp. The easiest way to do this is 

inside the Project window—just drag the Exploding Head comp on top of the Main 

comp. 

The Main comp should now have two layers, the sneeze orig.mov clip and the Exploding 

Head comp. Notice that the Exploding Head comp acts just like any other layer. You can 

move it, change its in- and out-points, and re-layer it. If you want to go back and change 

its contents you can, and those changes will automatically filter up to the Main comp. 

Re-position the Exploding Head comp so that it begins on frame 100 (Figure 17.22). 

 

 

Figure 17.22 With the Exploding Head comp properly positioned, the explosion will occur right 
after the actor has sneezed. 
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You can also add filters to a nested comp. Do that now by selecting the Exploding Head 

layer and choosing Effect>Simulation>Shatter. To get the best-looking shatter, you’ll 

need to change some settings in the Shatter filter dialog. Open the Shape property and set 

Pattern to Glass. 

Click on the crosshairs next to Shape Origin, and click in the comp window, just below 

the person’s nose. Set the Shape Repetitions to 20. Set the shape direction to about 60°, 

and set the Force 1 position to just above the person’s right eye. (Incidentally, there’s no 

science to determining these settings. These are simply parameters that we came up with 

after much trial and error. As you work through creating the shot, you might want to 

create a different-looking shatter.) 

In the Effects palette, change the View parameters for the Shatter filter to Rendered so 

that you can see the actual rendered effect. Step forward about five frames to see the 

beginning of the effect, then render a small test movie so that you can see the entire effect 

(or, if you have enough RAM, you can do a RAM preview within After Effects). (Figure 

17.23). 

 

 

Figure 17.23 The shattering head layer composited on top of our original background footage. 
Though our original, unshattered version is showing through, at least the shatterered layer is 
constrained to just the actor’s head. 
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Something’s very wrong, isn’t it? The shattering effect looks nice, but there’s still a head 

left behind. Obviously, the shatter effect can’t calculate what’s supposed to be behind the 

head in our original footage, so we’re going to need to create that information ourselves 

through some very tedious rotoscoping. 

Step 5: Start Rotoscoping 
In our Main comp, we have our original video layer, and a shattering copy of that same 

video layered on top of it. If our bottom layer was footage of a headless body, then when 

the top layer shattered, it would reveal the underlying headless footage and our effect 

would work. 

Unfortunately, we didn’t shoot footage of a headless body (we had cast a headless body, 

but he turned out to be a real prima donna and so we fired him), but we can create some 

headless body footage through rotoscoping. 

How to rotoscope is up to you. You could export the movie as a set of still files and 

repaint them in Photoshop. Alternatively, as we chose to do, you could open the movie 

file in After Effects and rotoscope it there. 

Your goal is to paint out the head, and build a collar and hole to go where the head used to be. 

After Effects has a Clone tool that works just like the Clone (or Rubber Stamp) tool in 

Photoshop. But, After Effects clone tool has the added benefit of being able to use other 

frames as a source for cloning. At the end of the original clip are a few frames of footage 

without the actor. We can use these as source frames to clone the background over the actor’s 

head in the earlier frames. (Figure 18.24). 
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Figure 18.24 In After Effects, we used the clone tool to clone background from an empty frame at 
the end of the movie into the frames where we want to erase the head. 
 

In the Timeline, double-click the sneeze orig.mov to open it up in layer view. Here you 

can begin cloning. Select the Clone tool in the Tool palette. In the Paint palette, make 

sure that both Aligned and Lock Source Time are checked. Normally, to clone, you 

would option-click on the area you want to clone from and then paint into the area you 

want to clone to. This procedure will work the same way, but first we want to select a 

frame to clone from. Scrub to the end of the click and find a frame that includes a clean 

shot of the wall behind the actor. Option click in any area of the frame, taking careful 

note of the X,Y coordinates in the Info palette. 

Now return to the frame you want to clone into (frame 100). Position your mouse at the 

same X,Y coordinates that you option-clicked in on the source frame, and click. You 

have now set up your cloning relationship. Now, you can brush in paint from the source 

frame into the current frame, effectively erasing the head to reveal the background. 

Carefully paint out the entire head, making sure to leave as much of the collar and shirt as 

possible. 

After Effects’ painting and cloning tools don’t actually change the pixels in the original 

image. Rather, the location of your paint strokes is stored in the After Effect project file. 

These paint strokes are composited onto the original media, providing you with a non-
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destructive form of editing. More importantly, though, because After Effects is 

remembering your actual strokes, it can composite them with all of the other frames in 

your movie, saving you a lot of painting time. 

In the Time Controls palette, click the Next Frame button to go forward one frame. You 

should see that this frame also has the head cloned out. In fact, all of the subsequent 

frames have been similarly cloned! However, though this is a great time-saver, it’s not 

perfect. 

Play the movie and you’ll see that, as the body moves around, it falls “behind” the paint 

strokes that you’ve created. Though After Effects has saved you a lot of time, you now 

have to go in and touch up some of your strokes. 

Return to frame 101. As you can see, the paint strokes that you originally made have 

erased part of the collar. You need to restore the collar by erasing the clone stroke that 

you painted here. Grab the Eraser tool, and select Paint Only from the Erase pop-up menu 

in the Paint palette. Brush over the collar with the erase tool to erase the clone strokes 

that are obscuring it. If you “erase” some of the head back into view, then use the Clone 

tool to brush it back out. (Figure 18.25) 

 

 

Figure 18.25 – Because our original clone strokes are inappropriate for this frame, we 

have to go in and erase some of those strokes using After Effects’ eraser tool. 
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As you can see, there’s no free ride with this kind of rotoscoping. Though After Effects 

has done a lot of the work for you by replicating your clone strokes onto every frame, you 

still have to perform some touch-up. 

You could perform the same rotoscoping task in any number of ways. Another example: 

• Export the frames you want to roto as numbered files into a folder. 

• Open the last file in Photoshop, one of the ones that is a shot of the empty, after 

the actor has wandered off. 

• Open the first frame that you want to roto, select all and choose copy to copy the 

entire frame. 

• Switch to the “empty room” frame that you opened first, and choose paste. This 

will paste the frame you want to roto into a separate layer above the “empty 

room” frame. 

• Using Photoshop’s erase tool, simply erase the head from the upper layer to 

reveal the room layer beneath. 

• Flatten and save and then repeat with the next frame you want to edit. (To save 

some time, build a Photoshop Action that automatically performs the copy and 

pasting of layers.) 

Alternatively, you could save the movie as Filmstrip format and use Photoshop’s clone 

tool to clone from one of the empty frames into your roto frame.  

As always, there’s no “right” way, and there’s no way around the fact that this type of 

roto work takes a lot of time. There’s a reason big budget effects movies are so 

expensive! 

Step 6: Build the shirt collar 
Once you’ve erased the head, you’ll need to build the back of the shirt collar, and fill in 

the hole where the head used to be. All of this can be painted in with black or dark tones 

of gray. As always, there are a lot of ways to do this. You can step through each frame in 

After Effects, and paint in the collar and hole, or you can export the frames to Photoshop 

or Painter and perform your edits there.  
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However, probably the easiest way is to use After Effects Pen tool to create an animated 

mask. 

Begin by selecting Layer>New Solid to create a solid layer of black in your composition. 

Position this layer just above the sneez orig.mov layer. The sneeze movie will be 

completely obscured by the black plate. Double-click on the color layer to open it in layer 

mode and use After Effects’ Pen tool to create a rough collar shape somewhere in the 

middle of the frame. Now click back to the Main comp to view it. You should see the 

rough black shape that you just drew, superimposed over the sneeze movie. This is the 

masked black layer that you created. 

Edit and reposition the mask to the appropriate shape, as shown in Figure 18.26. What’s 

great about this technique is that you can now tweak the collar mask’s control points on 

subsequent frames, and After Effects will automatically animate the shape and position of 

the mask for the intervening frames. (Figure 18.27) 
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Figure 18.27 – By clicking the stopwatch icon next to the Mask Shape property of the mask on 
our color layer, we can now edit the shape and the position of the mask at each frame where the 
headless body changes position. In this way, we can make the mask automatically follow and 
reshape the collar. In addition, note that we’ve added a slight feather to the mask’s edge so that it 
blends into the video. 

However you choose to do it, the process will take you a while. To save you some time, 

we have included on the companion DVD a rough, first pass of our rotoscoped movie, a 

file called sneeze roto.mov. Although a good place to start, this file still needs work to 

clean up some cloning artifacts, and to retouch and improve the collar and neck. For now, 

it will work fine. 
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Step 7: Add the Rotoscoped Movie 
Back in After Effects, replace the sneeze orig.mov movie in your Main comp with your 

new rotoscoped version. Render the movie (Figure 18.28). 

 

Figure 18.28 The same After Effects project, but now with the rotoscoped, headless version of 
our original footage. 
 

Now things are looking better! When the head explodes, you should see a headless body 

that staggers off-screen. 

However, the effect could still be better. The explosion looks like an animated explosion 

stuck on the front of a piece of video. It would be more realistic if the explosion had a 

sense of depth. Is there a way we could get some of the explosion parts to fly behind the 

body? Of course! 

What if we added another copy of the headless body, but this one with a matte, so that the 

explosion pieces are obscured by the matte? Obviously, we don’t want all of the 

explosion to fall behind the body, so we’ll create a second instance of the exploding head 

layer. This addition will also add drama to the shot by adding even more shattering 

debris. 
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Step 8: Mask the Body 
Unlike our head matte, the body matte that we’ll use to mask our second shatter effect 

will actually need to be a travelling matte. Using whatever technique you prefer, create a 

travelling matte of the relevant frames of the headless body movie. Obviously, you don’t 

need to worry about anything before frame 101. Take a look at your previously rendered 

movie to determine how long the explosion lasts. You don’t need to worry about masking 

any frames after this point. 

Again, we chose to use After Effects and created a simple, animated mask to follow the 

outlines of the body. We rendered the matte as a separate file, which is stored on the 

companion DVD as body matte.mov.  

Step 9: Add the New Explosion 
Back in After Effects, create a new comp called body w/matte. Put the sneeze orig.mov 

and body matte.mov files into the new composition. As before, set up body matte.mov to 

serve as the matte. 

Now, add the body w/matte comp to your Main comp. Put the current time marker at 

frame 106. As you can see, the body w/matte layer now obscures part of the explosion, 

making it look as if the shattered pieces are falling behind the body (Figure 18.29). 
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Figure 18.29 The shatter fragments now fly behind the body. 

 

Now we need to get pieces falling in front. In the Time Layout window, duplicate the 

exploding head comp. Drag the copy so that it is the topmost layer. Now you should see 

some pieces in front of the body as well. Note that, with the same settings, both copies 

will produce identical shatter patterns. Change the Shatter settings on one of the 

Exploding Head layers to create a different-looking explosion. We chose to change the 

lower layer to create the effect of pieces flying backward (Figure 18.30). 
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Fig 18.30a,b We managed to get shattering pieces to fly both in front of, and behind the body, by 
stacking several copies of the same layer. 

Now, render the movie. 

Looks better, but there’s still a problem. The shards of the top explosion fly in front of 

the actor’s right hand. Since the hand serves to indicate a lot of depth in the image, we 

should create yet another masked layer—this time of the hand—to put in front of 

everything else. 

Step 9: Matte the Hand 
Again, using your method of choice, create a matte for the relevant frames of the hand. 

As before, watch the original footage to try to determine which frames will interact with 

head fragments. You don’t want to worry about masking frames that don’t matter. 

Step 10: Add the Final Layer 
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Back in After Effects, create another comp called Hand. Add another copy of the sneeze 

roto.mov as well as a copy of the hand matte. Use Set Channels to set up your alpha 

channel. Add this comp to the Main comp and put it at the very top. 

Render the movie. 

Much better! Head parts are flying everywhere—in front of the body, behind the body, 

and behind the hand! However, we want to make one more small adjustment. 

The Shatter plug-in renders its fragments with very sharp, defined edges. The amount of 

sharpness doesn’t really match the quality of our original video, so we need to soften the 

explosion images up a bit to better match our source footage. 

Apply a Gaussian Blur filter to both of the Exploding Head layers. Set a Blurriness of 

2.0. You can experiment with more blur, but you don’t want to blur the images too much, 

or they’ll be blurrier than the source footage (Figure 18.31). 

 

 

Figure 18.31 The completed composite. 
 

Render the final movie, put it in your editing package, and look at it on your NTSC 

monitor. There you can better see how to fix the collar and neck rotoscoping, as well as 

look for any left-over clone artifacts. 
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After Effects and Echo Fire 

The latest version of After Effects  lets you preview movies on an 

external NTSC monitor via a FireWire cable and deck, just like in an 

editing package. This can save you a trip back to your editing 

program for NTSC previewing. 

To touch up the movie you can choose to re-paint your final movie, or go back and 

correct the sneeze roto.mov file, and then re-render your movie. Because we used 

multiple copies of that same movie, you can simply correct the original file and your 

changes will filter throughout your entire After Effects project. 

Performing your touch-ups on your final rendered movie might be the best choice, as you 

won’t waste time touching up areas that are obscured by falling debris. In addition, you 

can use the opportunity to smear the falling artifacts so that their motion quality better 

matches the footage of the actor. 

If you perform your touch-up in the original rotoscoped file, then you can always make 

other changes and improvements in After Effects, and re-render the file. 

You might also play with animating the values of the blur filters that you applied to the 

Exploding Head layers. By setting keyframes for the blurriness, you can make the 

fragments get more and less blurry as they speed up and slow down throughout the 

course of the explosion. 

As you can see, with just a single clip of video and some clever layering, you can create 

very complex effects. Ideally, you’ll need to do some planning before you shoot your 

initial footage. For the exploding head shot, for example, you might have been able to 

ease your rotoscoping work by shooting some additional photographic plates. In the end, 

you’ll want to weigh the time and money spent rotoscoping against the time and money 

needed to shoot multiple plates. 

 
 


